(534 votes)

Zeppelin Mod for Minecraft 1.7.4 / 1.7.2 / 1.6.4 & 1.5.2

Download Page for Zeppelin Mod


Additional Videos:



The Zeppelin Mod for Minecraft is one of the countless fan-created modifications you can install to increase your Minecraft experience. This particular mod gives you the ability to create their own flying machines, allowing fun and stylish new modes of transportation.

Once installed, you can create a basic zeppelin out of nothing more than three cobblestone blocks and three wooden planks, but you can add most other blocks to personalize and accent your personal flying craft. Most block types may be added to your aircraft, but a few such as bedrock, lava, and water cannot. To begin building your zeppelin or airship, arrange your cobblestone blocks across the middle row of your crafting field, with the wooden planks placed below the cobblestone. This will give you the necessary “Craft Controller.”

Now that you’ve got your Craft Controller, place it at where you’d like to be when steering your aircraft. When you right click on the Craft Controller, it will check the size of your craft and can function at up to 1,024 blocks. When you fly the craft, only blocks connected in some way to the ship will take off, with the rest remaining still. When engaging your craft, you can control ascent, yaw, and speed; these controls are defaulted to the numbers keypad to on the right side of most keyboards. 8 and 2 control speed, 6 and 4 affect the the “yaw” or degree of turning right or left (respectively), and the + and – keys control how steep or shallow the aircraft rises, with the 5 key setting all three fields to a value of zero. The * key will stop and align the ship to the map’s grid. It should be noted that you can move while the ship is running.



How to download & install:

  1. You’d need the Modloader for Zeppelin Mod
  2. Run the game
  3. Select “mods and texture pack”
  4. A folder should pop up
  5. select “mods” folder
  6. drag’n'drop the mods here
  7. (0.14+) only extract specific class files from the mod_Zeppelin-client.zip and put it in minecraft.jar
  8. DONE:



Related posts:

  1. Trains and Zeppelin Mod
  2. Zeppelin Mod Full
  3. Aircraft (Zeppelin) Mod
  4. More Health RPG Mod
  5. Decraftik Texture Pack

Related Links:

Download Page for Zeppelin Mod
  • Nick mac

    Great mod!!!!

  • Daxter33

    AWESOME my Minecraft USER IS DAXTER33 reminded._.
    |_|-_-|_|

  • O.O

    y a survey i can get if off minecraft forums for FREE!

  • Litdragon

    Will this mod be Forge compatable?

    • Nyquil

      DOES FORGE WORK

  • Csaba Boldizsár

    hol lehet letölteni???

  • devilman

    it keeps crashing my minecraft

  • tas

    not work

  • theminerockstar

    This website is most baddest webside iv ver seen theres too much adds and there i no download link all of the links that say there links are fake so this website sucks. minecraftDL is the best how ever this one sucks

  • Br0dstar

    The Mod Is Still At 1.2.5 And I Think The Developer Has Discontinued It :(

    • imhere

      no he has alot of stuff on and hes doing it in his spare time also doesnt help when minecraft is updating faster than he can.

  • Assar Diwanel

    piece of crap chrashed my minecraft

  • ggedas44

    lol

  • http://www.facebook.com/jackie.wu.3110 Jackie Wu

    Minecraft has crashed!

    ———————-

    Minecraft has stopped running because it encountered a problem; Exception occured in ModLoader

    This error has been saved to /Users/wuguoxian/Library/Application Support/minecraft/crash-reports/crash-2012-11-21_17.33.57-client.txt for your convenience. Please include a copy of this file if you report this crash to anyone.

    — BEGIN ERROR REPORT 1509cfde ——–

    Generated 11/21/12 5:33 PM

    - Minecraft Version: 1.4.2

    - Operating System: Mac OS X (x86_64) version 10.8.2

    - Java Version: 1.6.0_37, Apple Inc.

    - Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Apple Inc.

    - Memory: 493898056 bytes (471 MB) / 534708224 bytes (509 MB) up to 1065025536 bytes (1015 MB)

    - JVM Flags: 3 total; -Xbootclasspath/a:/System/Library/PrivateFrameworks/JavaApplicationLauncher.framework/Resources/LauncherSupport.jar -Xms512M -Xmx1024M

    - AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

    - ModLoader: Mods loaded: 11

    ModLoader 1.4.2

    mod_FCBetterThanWolves 4.33

    mod_Pokeball 1.3.1

    mod_PokeTrainer 1.3.1

    mod_TooManyItems 1.4.2 2012-10-25

    mod_ZanMinimap 3.1.4.2.0

    mod_Biosphere 1.4.2

    mod_CraftableMobSpawners 1.3.2

    Smart Moving 11.5

    Smart Render 1.0

    Timber! 1.4.2

    java.lang.VerifyError: (class: mod_Zeppelin, method: takenFromCrafting signature: (Lyw;Laan;Lio;)V) Incompatible argument to function

    at java.lang.Class.getDeclaredFields0(Native Method)

    at java.lang.Class.privateGetDeclaredFields(Class.java:2291)

    at java.lang.Class.getDeclaredFields(Class.java:1743)

    at ModLoader.setupProperties(ModLoader.java:1965)

    at ModLoader.addMod(ModLoader.java:373)

    at ModLoader.readFromModFolder(ModLoader.java:1425)

    at ModLoader.init(ModLoader.java:901)

    at ModLoader.addAllRenderers(ModLoader.java:215)

    at azw.(RenderManager.java:92)

    at azw.(RenderManager.java:14)

    at net.minecraft.client.Minecraft.a(SourceFile:259)

    at net.minecraft.client.Minecraft.run(SourceFile:515)

    at java.lang.Thread.run(Thread.java:680)

    — END ERROR REPORT 355f7eff ———-

    sorry about the space, please explain.

  • Rangolt

    Just wondering, what is the block limit for the mod?

    • boo

      1025

    • gyrotim

      It’s around 1025 blocks.

  • gdfgxdfg

    Nice Mod

  • Bob

    This isn’t really for 1.4.5. This site absolutely sucks. None of it’s mods work. Don’t trust this site@!!!!

  • Mark

    This site is total BS. Ive tried 5 different mods from here and they arent what they claim. Ive never had one of these work, this mod isnt even for 1.4.5

  • Bummbolt

    here are also for the 1.4.5

  • aled

    i keep getting an error repot

    *** MagicMinecraftLauncher 1.0.0 ***

    Disable inactive mods

    27 achievements

    java.lang.reflect.InvocationTargetException

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

    at java.lang.reflect.Method.invoke(Unknown Source)

    at magic.launcher.Launcher.main(Unknown Source)

    Caused by: java.lang.NoSuchMethodError: wu: method ()V not found

    at wn.(SourceFile:23)

    at wn.(SourceFile:14)

    at jq.d(SourceFile:103)

    at jq.b(SourceFile:82)

    at amq.(SourceFile:380)

    at bdm.(SourceFile:14)

    at net.minecraft.client.Minecraft.(SourceFile:126)

    at asq.(SourceFile:38)

    at net.minecraft.client.MinecraftApplet.init(SourceFile:38)

    at net.minecraft.client.Minecraft.main(SourceFile:1671)

    … 5 more

  • aled

    and this when i tried to fix it:

    Minecraft has crashed!

    ———————-

    Minecraft has stopped running because it encountered a problem; Exception occured in ModLoader

    A full error report has been saved to C:UsersaledthomasAppDataRoaming.minecraftcrash-reportscrash-2012-12-24_08.26.47-client.txt – Please include a copy of that file (Not this screen!) if you report this crash to anyone; without it, they will not be able to help fix the crash :(

    — BEGIN ERROR REPORT a7fa0d19 ——–

    Full report at:

    C:UsersaledthomasAppDataRoaming.minecraftcrash-reportscrash-2012-12-24_08.26.47-client.txt

    Please show that file to Mojang, NOT just this screen!

    Generated 24/12/12 08:26

    – System Details –

    Details:

    Minecraft Version: 1.4.6

    Operating System: Windows 7 (x86) version 6.1

    Java Version: 1.7.0_06, Oracle Corporation

    Java VM Version: Java HotSpot(TM) Client VM (mixed mode, sharing), Oracle Corporation

    Memory: 439154080 bytes (418 MB) / 518979584 bytes (494 MB) up to 518979584 bytes (494 MB)

    JVM Flags: 2 total; -Xms512m -Xmx512m

    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

    Suspicious classes: ModLoader, ModTextureStatic, EntityRendererProxy, …[Zeppelin.ItemRemoteControl]

    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

    ModLoader: Mods loaded: 1

    ModLoader 1.4.6

    java.lang.VerifyError: (class: mod_Zeppelin, method: takenFromCrafting signature: (Lyw;Laan;Lio;)V) Incompatible argument to function

    at java.lang.Class.getDeclaredFields0(Native Method)

    at java.lang.Class.privateGetDeclaredFields(Unknown Source)

    at java.lang.Class.getDeclaredFields(Unknown Source)

    at ModLoader.setupProperties(ModLoader.java:1970)

    at ModLoader.addMod(ModLoader.java:372)

    at ModLoader.readFromModFolder(ModLoader.java:1386)

    at ModLoader.init(ModLoader.java:911)

    at ModLoader.addAllRenderers(ModLoader.java:215)

    at bbu.(RenderManager.java:94)

    at bbu.(RenderManager.java:14)

    at net.minecraft.client.Minecraft.a(SourceFile:259)

    at asq.a(SourceFile:56)

    at net.minecraft.client.Minecraft.run(SourceFile:515)

    at java.lang.Thread.run(Unknown Source)

    — END ERROR REPORT f978676d ———-

  • ZEPPELIN

    PLEASE PLEASE SEND ME MORE SPECIFIC INSTRUCTIONS ON HOW TO INSTALL…..I KEEP ON FAILING …JUST REPLY ON THIS COMMENT

    • daswolfe

      get magic launcher it works realy great

    • whiteknight

      Get magic launcher. it loads mods easier. make a new folder, call it mods. move ur mods into the folder.put in either mod loader for forge and ur mods that u want on minecraft, whatever mod u need/want. then open up magic launcher. click ‘setup’ then click ‘add’. a list of folders will pop up. click the folder that says mods. find mod loader/forge. click on mod loader/ forge, then click ‘open’ that mod will be put on u list of download mods. if there is more than 3 errors DONT USE IT. get it from another site. once u have ur mods and forge/mod loader all open on ur screen click on ‘ok’.
      now all u need to do is click ‘login’. don’t worry if there isn’t a ‘mods’ thing that appers under multiplayer. the mods are still there. make a new world and call it ‘mods’ then goto creative and see the new items or too many items or xray mod, gems plus, what ever mod u have! there u go and ur done. happy crafting!

  • RMinecraftDK

    MY MOD CRASHED

    Minecraft has crashed!

    ———————-

    Minecraft has stopped running because it encountered a problem; Exception occured in ModLoader

    A full error report has been saved to C:UsersMitchAppDataRoaming.minecraftcrash-reportscrash-2012-12-28_14.39.16-client.txt – Please include a copy of that file (Not this screen!) if you report this crash to anyone; without it, they will not be able to help fix the crash :(

    — BEGIN ERROR REPORT 366d8bb5 ——–

    Full report at:

    C:UsersMitchAppDataRoaming.minecraftcrash-reportscrash-2012-12-28_14.39.16-client.txt

    Please show that file to Mojang, NOT just this screen!

    Generated 28/12/12 14:39

    – System Details –

    Details:

    Minecraft Version: 1.4.6

    Operating System: Windows 7 (amd64) version 6.1

    Java Version: 1.7.0_10, Oracle Corporation

    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation

    Memory: 385041688 bytes (367 MB) / 514523136 bytes (490 MB) up to 954466304 bytes (910 MB)

    JVM Flags: 2 total; -Xms512m -Xmx1024m

    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used

    Suspicious classes: ModLoader, EntityRendererProxy, ModTextureStatic, …[Zeppelin.ItemRemoteControl]

    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

    ModLoader: Mods loaded: 1

    ModLoader 1.4.6

    java.lang.VerifyError: (class: mod_ExtendedRenderer, method: OSDHook signature: (Lnet/minecraft/client/Minecraft;Z)V) Bad type in putfield/putstatic

    at java.lang.Class.getDeclaredFields0(Native Method)

    at java.lang.Class.privateGetDeclaredFields(Unknown Source)

    at java.lang.Class.getDeclaredFields(Unknown Source)

    at ModLoader.setupProperties(ModLoader.java:1970)

    at ModLoader.addMod(ModLoader.java:372)

    at ModLoader.readFromModFolder(ModLoader.java:1386)

    at ModLoader.init(ModLoader.java:911)

    at ModLoader.addAllRenderers(ModLoader.java:215)

    at bbu.(RenderManager.java:94)

    at bbu.(RenderManager.java:14)

    at net.minecraft.client.Minecraft.a(SourceFile:259)

    at asq.a(SourceFile:56)

    at net.minecraft.client.Minecraft.run(SourceFile:515)

    at java.lang.Thread.run(Unknown Source)

    — END ERROR REPORT b5047443 ———-

  • sada

    is this for 1.4.2 1.4.5 1.4.4

  • imperson8

    y does it not work and keeps crashing my minecraft

  • VI=6

    This mod only works for 1.2.5, the moder itself must update it to be used for 1.4.7

  • madafaka

    VIRUS!

  • leeinaustin

    the mod doesn’t work for me! cann someone help me?

  • Cooper217

    Is this pretty much the same as the one Blackmajic (sorry if spelled wrong) made? I’ve been searching for it or like it, not like movecraft.

  • Msd

    UPGRADE THE MOTHER FAHKIN MOD!!!!!!

  • Bobo

    HOW THE F*** DO YOU INSTALL THIS

    • adam

      it is so hard it sucks right

  • ik

    hi people listen to this: the zeppelin mod stopped updtaing since version 1.2.5

  • Andreas

    This mod is not for 1.4._, isn’t it?

  • Please put the download link!

    this is gonna be my new favourite mod if i am able to download it!
    Olz put the download linnk plz plz plz plz plz plz plz plz plz!!!

  • Please put the download link!

    is this for the latest version or the old versions

  • BlankMagnum

    Lol this is a virus!

  • Thecoon

    This is a fake it doesn’t work because it’s for 1.2.5, these faggots make you download it by saying its the current update

    • They never said the version…

      • Pecacheu

        Actually, the header for the page CLEARLY says “Zeppelin Mod For Minecraft 1.4.7 / 1.4.6 / 1.4.5″ That’s EXACTLY what is says! Websites like these lie a lot about the versions of mods though, So I’m not surprised.

    • Minecrafter

      Yeap, I think so…

  • maciek

    chciałem mod na 1.3.2 a co dostałem? jakoś na wersje gównianą!!!!!!!!!!!!!!!

  • minecraftisepic89

    boring does not work for 1.4.7

  • butterhead44

    cant they fix it with modloader MP?

  • TacoMuffinCow

    uhh…. Non filecopter download? please?

  • Fraser Hamilton

    Is this Forge compatible or no ?

  • DjGolldRUS

    no

  • DjGolldRUS

    Looking for this mod for 147 I can not find

  • http://twitter.com/KiddabobProject Mitchell Stamp

    you need to make this work for 1.4.7 and higher because this is a good mod

  • jack

    does this mod work on 12.2?

  • Scarlet Rain

    this mod isnt been updated since 1.2.5, all that says its for a more recent version and isnt coming from the originial modder, its a fake

  • Tim

    It’s been like 7 months since 1.2.5 was out and this mod still hasn’t been updated! 1/5

  • secretqwerty10

    if you use this with particle deco and make a huge boat it will be awesome!

  • Ajt86

    Lucky I made a backup of my minecraft.jar before placing wu.class otherwise I’d have had to reinstall FML, optifine, etc :D ALWAYS BACKUP YOUR .MINECRAFT WHEN MESSING AROUND WITH IT

    • JarsCollector

      i have a folder with alot of minecraft.jar backups…in there… theres 3 folders

      1.4.7 jar
      1.4.6 jar
      1.4.2 jar

      and in 1.4.7 there is some more jars like “The default one i liked to use” the fun one fresh one…. and more… my backups are better than you…

  • fauzi

    I am a very long time to waiting , it works or not

  • cRAZYpERSON

    SHUT UP SHUT UP SHUT UP! IT FREAKING SAYS IT’S MODLOADER, FAGGOTS!

    • InfiniteAtom

      hey cRAZYpERSON

      do not be a jerk nobody likes a jerk cRAZYpERSON

  • bowserbnoss21

    is the zeppelin mod forge compatable?
    PLZ RESPOND

  • JustDon’t

    DONT DOWNLAOD!!!!! DOESNT WORK!!!!! The ORIGINAL mod makers need to update it.
    these Pirates say its up-to-date!

    • Minecrafter

      Yeap, all mods from this page are the same, doesn’t work for any version!

  • Miner132

    i really want this… bad thing… the mod maker haven’t updated it yet… because the update was so fast… then!!! 1.5 is out!… Now the mod maker have to update it directly to 1.5 … Notch should stop updating for a while… because some great mod makers is busy studying and stuff and they can’t update in time because of lacking spare times…..

    Notch should rest his brain full of ideas for a while…

    changing to version 1.2.5 when playing with this… i really want to try this mod in 1.4.7….

  • colton

    PLEASE TELL ME IF THIS MOD IS COMPATIBLE WITH FORGE MOD LOADER! REPLY QUICKLY!

  • colton

    ALSO IS THERE A 1.4.7 VERSION?

  • Grimsly

    umm the block limit is 3000

  • http://www.facebook.com/brian.weatherall.9 Brian Weatherall

    great job

  • testnutzer

    gibt es diesen mod auch für 1.5.1? … bei mir klappt dies sonnst nich!

  • Minecrafter

    It doesn’t work with Forge, yes, I’ve alredy tried!
    After MOJANG logo appears screen turns black.

  • Minecrafter

    I have downloaded a lot of works here from this page and the number of mods downloaded from this page is: 0. I repeat, 0. AGAIN 0000000!!!!!!

  • joe

    forge works

  • Minecraft

    Somebody please tell me the Download Link

  • Asker

    it,s for minecraft 1.5.1

    • Asker

      or 1.4.7?

  • C:Lollipopia

    what version is this for?

  • :(

    i dont want mod loader

  • not a noob

    its a modloader mod and only works wih 1.4 to 1.5.1 and also use the magic launcher as it works well awesomely

  • http://www.facebook.com/profile.php?id=100000537339219 Daniel Harpst

    I dont think this mod is compatible with 1.5.1 Someone dropped the ball

  • http://www.facebook.com/profile.php?id=100000537339219 Daniel Harpst

    I wish I could go back into time and force the op’s mom to have an abortion.

  • Octane154

    This is much easier to install with the magic launcher

  • Bob

    Omg this only has adds and wont let me get it!

  • Torsten Peter

    can you please give me your minecraft.jar with the zeppelin mod?

    I’m too stupid to install the mod

  • mati

    fajny modzik

  • Giovanni

    how u can download this

  • Guest

    if i open my LAN connection, will i be abble to

  • http://www.facebook.com/gabriel.cordeiro.754 Gabriel Cordeiro

    If I open my LAN connection, will my friends see the mod?

    • toothlessblue

      Teh answer to this is no! they need the mod as well

  • kingkewl

    does it work w/ ftb ultimate?

  • Elijahpederson

    This is a virus that will take over your computer, do not download it.

    Ban the poster, delete the article. Ban the poster, delete the article. Ban the poster, delete the article. Ban the poster, delete the article. Ban the poster, delete the article. Ban the poster, delete the article. Ban the poster, delete the article.

  • good

    good

  • mijmsada

    Screw Adds!

  • Dylan Lieggi Il Babaman

    we

  • Dylan Lieggi Il Babaman

    polpe

  • JBcaptain

    MAKE ANOTHER DOWQNLOAD LINK I CANT DOWNLOAD I DONT HAVE TWITTER OR ANY OF THAT JAM JARS!!!!!!!!!!!!!!!!!!!!

    • A-Non-Scam-Corporation

      Ah you should have an email. You don’t have? Make one.

  • xXKarmaLlamaXx

    IM GETTING BLACK SCREENS!!!

    • InfiniteAtom

      you clicked the black download button, the black download button is not the actual download, the actual download is the red download button. =)

  • haahahahah

    crash

  • Furious Right Now.

    The worst download links on this website, and they don’t even work. How bloody fantastic.

  • Orangeboxfreak23

    i need forge to be compatable so i can use my other mods i have installed

  • Penguin

    Where do I download???

  • Ryan

    Can you make it for a bukkit server?

  • Hector

    Does this work for minecraft 1.5.2?

  • Hector

    My screen turned black

  • the_wargod

    lol this mod looks fun

  • the_wargod

    yay

  • PowerBowser

    Please stop acting like every mod is up to date. The google search result says this is for version 1.6.2, but it clearly isn’t. Even if this isn’t some intentionally dishonest way to raise traffic, it is annoying and makes me want to avoid the site.

  • kd

    poo poo

  • kc

    no proper downloads :o :(

  • Anyname

    you are forced to give some personal information for like the download or subscribe to newsletter, and if you pass this the download link is broken!

    Very Very Funny!!!!

  • skythekidGH

    the download link is broken :(

  • I wont tell…

    Can you upgrade it to 1.6.2?

    • tecksup

      no and by the way its STILL 1.2.5 so good luck using the mod anyways

  • rykanohi1

    hey can u upgrade this to 1.6.2

    • ninja

      i know right

  • Markus persson

    I want to download this mod, and I see redcopter page!!

    —please, mute redcopter, please!—

  • EpicGavinNorman

    WERE IS 1.6.2 update it im waiting!!!!!!!!!!!!!!

  • andre_mac

    this broken

  • andre_mac

    and fix it

  • Lucas

    Waiting Big Time For Version 1.6.2 My Favorite Mod ^_^

  • 1

    how do i download it? there are like 10 different download buttons and none of them work!

  • PrometeoPrime

    please make zeppelin mod for 1.6.2

  • MINE CRAFTED

    the downloads link is broken

  • aman

    where is the mod texture pack

  • Mr. Hymn

    I can’t download this mod.

  • InfiniteAtom

    this link is a attempt to hack your computer use caution when using this website

  • herobaseball29, Team TDM

    A lot of the links ARE viruses, yes, (I learned that the hard way and spent a year saving the computer) But the one that actually says download zeppelin mod for minecraft Works, the red one at the bottom works

  • john john

    this is rubbish the download does’nt work..

  • tom tom mas mas

    lol fucker it doesnt work -_-

  • zeinkai

    make it 1.7.2 i mean common

  • NinjaNate2000

    Is there a way to have more than 1024 blocks be on a single boat or airship? If not, make an extender for this to be possible in 1.7.3.

  • Bruce

    help, whenever i try to download, it sends me to video downloader

  • Bruce

    clicking the bottom one doesn’t work