(208 votes)

Trains and Zeppelin Mod for Minecraft 1.7.4 / 1.7.2 / 1.6.4 & 1.5.2

Download Page for Trains and Zeppelin Mod


Additional Videos:



The Trains and Zeppelin Mod for MineCraft allows players to build and move about the game using a train system or a zeppelin instead of using the mine cart system, as well as offering players additional cart models. This mod lets you explore MineCraft the way you know and love, just in a whole new way. That means that this mod isn’t going to change the how you play MineCraft, only the way you move about the game.

Transportation by train offers a smoother, faster ride than the mine carts you are used to. The Trains and Zeppelin mod can hours of game play with the ability to create and build your own tracks. This mod also features over 80 train models, including 3 new steam locomotives and 2 diesel locomotives, an electric tram and an electric locomotive. In addition to using trains as a means of transportation, you can also add inventory to the trains as cargo.

By giving the player the control to build tracks, choose the train carts and even the sound effects the possibilities are endless. So whether you are a train enthusiast or just want a new level of MineCraft fun this mod truly delivers.



How to download & install:

  1. Download Minecraft Forge API here.
  2. Download Traincraft here
  3. Install Forge FIRST!
  4. Place the .jar in mods folder in .minecraft folder (Mods folder in “edit mods” if using MultiMc)
  5. You’re done. Go play



Related posts:

  1. Zeppelin Mod
  2. Zeppelin Mod Full
  3. Aircraft (Zeppelin) Mod
  4. Lego Mod
  5. Monster Spawn Highlighter Mod

Related Links:

Download Page for Trains and Zeppelin Mod
  • lpb007

    how do i fix the destilation tower click bug? HELP

  • austin hammack

    mine doesnt have the train config file plese help

  • Leyoo

    the game does not work. and file does not appear “Trainconfig.txt”

  • Your mom

    GUYS GUYS! THIS IS FOR 1.2.5!

  • Jack

    come on i downloaded it and id doesnt work there liers

  • gyrotim

    What is the point of making a mod that doesn’t even work!?

  • asd

    Doesnt work -.-

  • kiran

    thanks i love you

  • thedoctor10034

    i know right

  • ColbyMan9

    screw this

  • http://twitter.com/guizdcash Guilherme Z. Daniel

    the mpmodloader is for minecraft 1.3.2

  • Destroyer

    Works! I have 1.4.7 :P

    • batman

      you should put a link to download you minecraft.jar cuz i cant figure out how to install it

  • Sparda3092

    worked for me guess you guys aren’t doing it right then.

  • flo

    WHY?!??
    what is my fault?
    Instance started with command:

    “java” -Xms512m -Xmx1024m -jar MultiMCLauncher.jar “floef” “7238847019674102352″ “MultiMC: asdf” “854×480″ “Mojang”

    Loading jars…

    Loading URL: file:/C:/Users/Flori/Downloads/instances/asdf/minecraft/bin/minecraft.jar

    Loading URL: file:/C:/Users/Flori/Downloads/instances/asdf/minecraft/bin/lwjgl.jar

    Loading URL: file:/C:/Users/Flori/Downloads/instances/asdf/minecraft/bin/lwjgl_util.jar

    Loading URL: file:/C:/Users/Flori/Downloads/instances/asdf/minecraft/bin/jinput.jar

    Loading natives…

    java.lang.SecurityException: Invalid signature file digest for Manifest main attributes

    at sun.security.util.SignatureFileVerifier.processImpl(Unknown Source)

    at sun.security.util.SignatureFileVerifier.process(Unknown Source)

    at java.util.jar.JarVerifier.processEntry(Unknown Source)

    at java.util.jar.JarVerifier.update(Unknown Source)

    at java.util.jar.JarFile.initializeVerifier(Unknown Source)

    at java.util.jar.JarFile.getInputStream(Unknown Source)

    at sun.misc.JarIndex.getJarIndex(Unknown Source)

    at sun.misc.URLClassPath$JarLoader$1.run(Unknown Source)

    at sun.misc.URLClassPath$JarLoader$1.run(Unknown Source)

    at java.security.AccessController.doPrivileged(Native Method)

    at sun.misc.URLClassPath$JarLoader.ensureOpen(Unknown Source)

    at sun.misc.URLClassPath$JarLoader.(Unknown Source)

    at sun.misc.URLClassPath$3.run(Unknown Source)

    at sun.misc.URLClassPath$3.run(Unknown Source)

    at java.security.AccessController.doPrivileged(Native Method)

    at sun.misc.URLClassPath.getLoader(Unknown Source)

    at sun.misc.URLClassPath.getLoader(Unknown Source)

    at sun.misc.URLClassPath.getResource(Unknown Source)

    at java.net.URLClassLoader$1.run(Unknown Source)

    at java.net.URLClassLoader$1.run(Unknown Source)

    at java.security.AccessController.doPrivileged(Native Method)

    at java.net.URLClassLoader.findClass(Unknown Source)

    at java.lang.ClassLoader.loadClass(Unknown Source)

    at java.lang.ClassLoader.loadClass(Unknown Source)

    at MultiMCLauncher.main(MultiMCLauncher.java:157)

    Minecraft exited with code 4.

    Minecraft has crashed!

  • The Guy Who Got The Mod Workin

    WORKS FINE !

  • Nagisa

    i have 16 mods and i have the trains but i can’t place them!!!!!!!!!!!!!
    HELP PLEASE

  • Ajt86

    Works fine for me and I already have 40 mods installed :)

  • mitch

    delete meta inf inside traincraft.jar

  • Angryman

    Waste of time. this mod just does not work at all.

  • atomicman

    you guys have to follow instructions! it worked for me skype me and i can help you out : atomictoddler

  • theepicdude

    i just get a black screen after the mojang screen comes up
    plz help

  • http://www.facebook.com/tyler.mcgill.71 Tyler McGill

    why does it say the mod is for 1.4.6 1.4.7 1.5 and 1.5.1? it does not work above 1.5 because no one has been updating it since 1.4.6 and the 1.5 version wont work for 1.5.1

  • Bear

    It does work it’s just a bad download :(

  • lala4900

    Come on! You said that this is the real mod, I downloaded it, and it doesn’t work… Dond download this if you have 1.5.1, it doesn’t work!

  • Robert

    The mod needs to be updated it only works for 1.4.7 rite now.

  • Watkins

    doesn’t work i get black screen after mojang

  • st_roadrunner

    download doesn’t work

  • The162Guest

    It will not work with 1.6.2 :L

  • Trainmaster909

    I downloaded the mod and it does not work, I cannot play minecraft. Update the mod to work with 1.6.2

  • clarenz

    how to download